Ahmad Faizin

"Sebarkan ilmu walau hanya satu ayat ^^"

Random Posts

Banner

Breaking

BitMiner - free and simple next generation Bitcoin mining software

Monday, 16 January 2017

VTP (Vlan Trunking Protocol) | Cisco Packet Tracer

Assalamu'alaikum Wr. Wb. Setelah kita belajar membuat dan menghubungkan vlan, saya akan membahas cara meng-advertise vlan. Yaitu dengan menggunakan VTP atau Vlan Trunking Protocol. Didalam VTP ini ada 3
mode untuk setiap switch nya , yaitu :
1. VTP Server
2. VTP Tranparent
3. VTP Client.

Sebelum melakukan konfigurasinya, kita bahas terlebih dahulu tentang VTP itu.

  • Pengertian 
  VLAN Trunking Protocol (VTP) adalah Cisco protokol khusus yang menyebar definisi Virtual Local Area Network ( VLAN ) pada jaringan area lokal secara keseluruhan.
  • Latar Belakang
Secara default semua switch merupakan VTP Server.
Yang perlu diketahui tentang 3 mode itu adalah sebagai berikut :
Jadi kita ingin melakukan pengubahan mode switch dari defaultya merupakan VTP Server dan akan diubah menjadi VTP Transparent dan VTP Client.
  • Maksud dan Tujuan
  Ingin mempelajari tentang konsep dari VTP dan agar mengerti dan dapat melakukan konfigurasi VTP, baik VTP Server, VTP Transparent dan VTP Client. 
  • Jangka waktu 
  Jangka waktu yang dilakukan untuk konfigurasi pada topologi ini kurang lebih 15 sampai 30 menit.
  • Alat dan Bahan
  1. PC 
  2. Cisco Packet Tracer (Installed)
  • Langkah Kerja
1. Pertama kita buat topologi jaringan terlebih dahulu. Untuk topologi jaringan yang saya buat seperti dibawah ini



2. Nah setelah membuat topologi, langsung saja kita mulai konfigurasi nya. hal pertama yang harus dilakukan adalah mengaktifkan fitur Trunk pada Interface VLAN pada semua Switch , agar dapat saling terkoneksi. INGAAT SEMUA SWITCH ! 

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface range fa 0/1-2
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#exit
Switch(config)#

Lakukan konfigurasi diatas untuk semua switch

3. Setelah itu kita berikan nama pada setiap Switch agar tidak bingung pada saat konfigurasi
Switch-A

Switch-B

Switch-C

Switch-D 

4. Kemudian kita setting IP untuk interface Vlan 1 untuk masing-masing switch. Kita buat IP nya sesuai dengan topologi diatas
Switch-A
Switch-A(config)#interface vlan 12
Switch-A(config-if)#ip address 10.10.10.1 255.255.255.0
Switch-A(config-if)#no shutdown

Switch-B
Switch-B(config)#interface vlan 12
Switch-B(config-if)#ip address 10.10.10.2 255.255.255.0
Switch-B(config-if)#no shutdown

Switch-C
Switch-C(config)#interface vlan 12
Switch-C(config-if)#ip address 10.10.10.3 255.255.255.0
Switch-C(config-if)#no shutdown

Switch-D
Switch-D(config)#interface vlan 12
Switch-D(config-if)#ip address 10.10.10.4 255.255.255.0
Switch-D(config-if)#no shutdown
5. Sekarang kita masuk ke konfigurasi VTP nya , pertama yang harus diperhatikan adalah kita harus membuat VTP Domain yang sama dan juga Password nya. Dan tentunya jenis dari VTP untuk setiap switchnya.
Switch-A
Switch-A(config)#vtp mode server
Switch-A(config)#vtp domain Faiz
Switch-A(config)#vtp password Ahmad

Switch-B
Switch-B(config)#vtp mode transparent
Switch-B(config)#vtp domain Faiz
Switch-B(config)#vtp password Ahmad

Switch-C
Switch-C(config)#vtp mode client
Switch-C(config)#vtp domain Faiz
Switch-C(config)#vtp password Ahmad


Switch-D
Switch-D(config)#vtp mode server
Switch-D(config)#vtp domain Faiz
Switch-D(config)#vtp password Ahmad

6. Setelah sudah kemudian test dengan membuat Vlan di setiap Switch. Seperti berikut

Switch-A
Switch-A(config)#vlan 10
Switch-A(config-vlan)#name VLAN-A

Switch-B
Switch-B(config)#vlan 20
Switch-B(config-vlan)#name VLAN-B

Switch-C
Switch-C(config)#vlan 30
VTP VLAN configuration not allowed when device is in CLIENT mode.
Switch-C(config)#
 “( SWITCH VTP CLIENT TIDAK BISA MEMBUAT VLAN)”

Switch-D  
Switch-D(config)#vlan 40
Switch-D(config-vlan)#name VLAN-D
7. Dari gambar diatas bisa dilihat bahwa semuanya dapat membuat vlan kecuali yang ber-mode CLIENT. Selanjutnya kita lakukan verifikasi, dengan cara lihat jumlah Vlan yang ada di setiap switch, jika berhasil maka semua switch KECUALI Switch-B atau switch yang bermode Transparent akan memiliki jumlah Vlan yang sama. Jumlah vlannya adalah 2 Vlan , yang dibuat oleh Switch-A dan Switch-B.Berikut contoh nya

Switch-A 


Namun untuk jumlah vlan yang ada di Transparent hanya satu yaitu vlan yang
dibuatnya sendiri. Dan vlan ini tidak disebar ke Switch lain , makanya kita tidak
melihat VLAN-B atau vlan dari switch-B.

Switch-B 

 Dan untuk vlan yang ada di Client dia mengikuti pada vlan yang berada pada server.

Switch-C

  • Kesimpulan 
  Jadi dari konfigurasi diatas, kita jadi lebih mengerti tentang perbedaan dari ketiga VTP tersebut. Jadi untuk VTP Transparent dia memiliki mode yang berdiri sendiri, maksudnya dia dapat membuat vlan dan untuk diri sendiri dan tidak di bagikan. Dan untuk VTP Server dia dapat membuat vlan dan nantinya dibagikan pada VTP yang mode nya VTP Client. Sedangkan VTP Client dia tidak dapat membuat vlan, tetapi dia menerima vlan dari VTP Server.


NB : Untuk konfigurasi yang lain bisa lihat DISINI

Mungkin hanya ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb.  

No comments:

Post a Comment

Adbox