Ahmad Faizin

"Sebarkan ilmu walau hanya satu ayat ^^"

Random Posts

Banner

Breaking

BitMiner - free and simple next generation Bitcoin mining software

Thursday, 12 January 2017

Konfigurasi Routing Dynamic Jenis OSPF Pada Cisco Packet Tracer

Assalamu'alaikum Wr. Wb. Pada kesempatan kali ini saya ingin mencoba konfigururasi Routing Dynamic dengan jenis OSPF. Nah. untuk melakukan konfigurasi ini saya ingin membahas terlebih dahulu tentang OSPF ini. Yuk langsung saja kita bahas.

  • Pengertian 
  Open Shortest Path First (OSPF) adalah routing protocol untuk Internet Protocol (IP) jaringan. Ini menggunakan link state routing yang algoritma (LSR) dan jatuh ke dalam kelompok protokol routing interior , yang beroperasi dalam satu sistem otonom (AS). Hal ini didefinisikan sebagai OSPF Versi 2 di RFC 2328 (1998) untuk IPv4 . Update untuk IPv6 ditetapkan sebagai OSPF Versi 3 di RFC 5340 (2008).
  OSPF adalah mungkin yang paling banyak digunakan interior gateway protocol (IGP) di jaringan perusahaan besar. Menengah Sistem untuk Sistem menengah (IS-IS), link-state protocol routing dinamis lain, lebih sering terjadi pada besar penyedia layanan jaringan.
  • Latar Belakang
  Hal yang melatarbelakangi kegiatan pada kali ini adalah, saya ingin mempelajari Routing Dynamic dengan jenis OSPF. Pada postingan sebelumnya saya sudah mempelajari routing static dan routing dynamic jenis RIPv1 dan sekarang saya mencoba routing dynamic jenis OSPF.
  • Maksud dan Tujuan 
  Maksud dan tujuan dari kegiatan kali ini saya ingin mempelajari tentang routing dynamic jenis OSPF dan ingin memahami tentang routing dynamic jenis OSPF ini.
  • Jangka Waktu 
  Jangka waktu yang dilakukan untuk konfigurasi Routing OSPF pada Cisco Packet Tracer kurang lebih 1 jam hingga melakukan Trouble Shooting.
  • Alat dan Bahan
  1. PC 
  2. Cisco Packet Tracer (Installed)
  • Langkah Kerja
1. Pertama kita buat topologi jaringan terlebih dahulu, nah untuk saya membuat topologinya seperti dibawah.



2. Setelah itu, kita konfigurasi IP Address pada setiap router terlebih dahulu. Saya konfigurasi pada Router 1 terlebih dahulu menggunakan CLI.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 192.168.11.1 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#
3. Nah setelah itu kita konfigurasi IP Address pada router 2. Sesuaikan dengan interface yang terhubung.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface se 2/0
Router(config-if)#ip address 192.168.11.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se3/0
Router(config-if)#ip address 192.168.12.1 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

4. Dan yang terakhir kita konfigurasi IP Addres pada router 3.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface se 2/0
Router(config-if)#ip address 192.168.12.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

5. Nah setelah kita mengkonfigurasi IP Address pada setiap Router, maka kita bisa konfigurasi Routing dynamic jenis OSPFnya. Sebelum melakukan konfiurasi kita harus tahu beberapa perintah dan fungsi dari perintah yang kita tuliskan tersebut
Router(config)# router ospf <process-id>
Router(config-router)# network <network-id> <wildcard-mask> area <area-id>

Keterangan:

  1. <Network-id>: IP Network yang akan di advertise 
  2. <Area-id>: nomer area, 0 (backbone area) 
  3. <wildcard-mask>: inverse nilai biner(bit) SubnetMask. 
  4. <process-id>: nomor dari ospf yang akan di konfigurasi
Nah langsung saja kita konfigurasi OSPF pada Router 1. Dibawah ini adalah beberapa konfigurasi pada Router 1
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 120
Router(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router(config-router)#network 192.168.11.0 0.0.0.3 area 1
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

6. Nah setelah konfigurasi pada Router 1, kita bisa konfigurasi OSPF pada Router 2. Dibawah ini adalah beberapa contoh konfigurasi OSPF pada Router 2
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 120
Router(config-router)#network 192.168.11.0 0.0.0.3 area 1
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.12.0 0.0.0.3 area 1
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

7. Nah setelah kita konfigurasi pada Router 1 dan Router 2 maka kita bisa konfigurasi pada Router 3. Konfigurasinya seperti dibawah
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 120
Router(config-router)#network 192.168.12.0 0.0.0.3 area 1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

8. Sebenarnya pada ketiga router tersebut sudah dapat berkomunikasi. Nah tadi kitakan baru konfigurasi pada Router. Sekarang kita memberi IP Address pada setiap Client agar dapat berkomunikasi satu sama lain.

PC Client pada Router 1


PC Client pada Router 2


PC Client pada Router 3

9. Nah, setelah kita selesai konfigurasi Router dan PC Client. Cobalah kita mengirim pesan antar Client dengan router berbeda. ketika ada keterangan "Successful" maka kita berhasil mengkonfigurasi Routing nya. Tetapi ketika ada keterangan "Failed" maka coba cek konfigurasinya. mungkin masih ada yang salah pada saat konfigurasi tadi.


10. Nah untuk kita ingin melihat jalur yang dilewati oleh client, kita harus tahu IP Address milik target. Dn kita bisa coba seperti dibawah

PC Client Router 1 ping ke PC Client 3

PC Client Router 3 ping ke PC Client 1

PC Client Router 2 ping ke PC Client 1
dan
PC Client Router 2 ping ke PC Client 3
  • Kesimpulan
  Jadi kita sudah berhasil melakukan konfigurasi Routing Dynamic jenis OSPF, dan ketika kita melakukan touring pada Cisco Packet Tracer kita bisa lihat jalur mana saja yang dilalui untuk berkomunikasi dengan cara "tracert"
  • Referensi
  1. https://en.wikipedia.org/wiki/Open_Shortest_Path_First  

   Teman teman yang ingin mempelajari tentang konfigurasi OSPF seperti diatas bisa Download DISINI
NB : Untuk konfigurasi yang lain bisa lihat DISINI

Mungkin hanya ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb.

No comments:

Post a Comment

Adbox